Need help redoing website certification

Hi,

I messed up the process and now I can't fix it. Probably it would be faster to restart the certification stage instead of correcting it. I re-run certbot several times and modified files in /etc/apache2/sites-available.
woa.ro, without https, works. With https it is not able to load.
webmail.woa.ro redirects to https and doesn't work either. Plain http worked at the beginning but I broke that, too.

Help would be greatly appreciated.

My domain is: woa.ro

I ran this command: many. Followed linuxbabe's tutorial and made some mistakes during the process.

It produced this output: Firefox says Unable to load.

My web server is (include version): Apache 2.4.52

The operating system my web server runs on is (include version): Raspberry OS (Debian 11-based) 64 bit

My hosting provider, if applicable, is: RCS & RDS S.A.

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no. SSH only

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.12.0

1 Like

Welcome @csabix

Your first problem is you do not have any DNS entries for your domain names.

nslookup woa.ro
** server can't find woa.ro

nslookup webmail.woa.ro
** server can't find webmail.woa.ro

For future testing, see

3 Likes

Hi @csabix and welcome to the LE community forum :slight_smile:

You wouldn't be the first that has lost sight of the instructions while paying attention to a babe.
Can you undo/redo the process(es) [start over] ?

3 Likes

The server was down. I turned it off.
Now it's on.

2 Likes

"Can you undo/redo the process" - that was my question.
giving a more general answer, yes. I can start all over again but this process is more than 10 hours long and I'd really hate redoing all steps. The risk of making other mistakes is high.
So, I'd preferably avoid an infinite amount of work and would just fix one issue.

2 Likes

In the meantime I found that I can delete certificates with the certbot delete command.
Deleted everything and remade it but still no result.

Do you have port 443 open? I see your site now and I can connect to http://woa.ro which redirects to https://woa.roa. That's fine but https fails to connect. These are ports I see:

53/tcp   open   domain
80/tcp   open   http
143/tcp  closed imap
465/tcp  open   smtps
587/tcp  open   submission
1723/tcp closed pptp
4 Likes

Thanks a lot for the idea!
Didn't think it can be a problem inside the network. But the way my DNS is configured, no wonder, though.
Now I have some 403 Forbidden errors. Will work on that and I'll come back with the results.

5 Likes

Thanks again!
Problem solved.

4 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.