My updated ssl cert won't show publicly


#1

I ran

sudo certbot certonly --cert-name gulfbreeze.com -d gulfbreeze.com,mail.gulfbreeze.com,new.fight.tv,www.gulfbreeze.com,yourname.fight.tv,fans.email,mail.fans.email --preferred-challenges http

And I was able to add two new domains to my cert: fans.email and mail.fans.email. When I display my certs, these domains show as being part of the cert.

However, the cert isn’t working for fans.email, and SSL Checker doesn’t see the domain either.

My domain is: fans.email

I ran this command: sudo certbot certificates

It produced this output:

Found the following certs:
Certificate Name: gulfbreeze.com
Domains: gulfbreeze.com fans.email mail.fans.email mail.gulfbreeze.com new.fight.tv www.gulfbreeze.com yourname.fight.tv
Expiry Date: 2018-11-07 14:36:27+00:00 (VALID: 89 days)
Certificate Path: /etc/letsencrypt/live/gulfbreeze.com/fullchain.pem
Private Key Path: /etc/letsencrypt/live/gulfbreeze.com/privkey.pem

My web server is (include version): Apache2

The operating system my web server runs on is (include version): Ubuntu 16.04

My hosting provider, if applicable, is: Linode

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No


#2

Have you reloaded Apache since you issued the new cert?


#3

Hi @3x5

your certificate looks good:

https://transparencyreport.google.com/https/certificates?cert_search_auth=&cert_search_cert=&cert_search=include_expired:false;include_subdomains:false;domain:gulfbreeze.com&lu=cert_search

With 7 domain names. But certbot certonly doesn’t install the certificate.

So you have to use the files

in your Apache configuration.

Your gulfbreeze.com uses a certificate created 2018-07-06 with 5 names.

There change the path + filename to your new certificate.


#4

Thanks so much, I just needed to restart Apache. I’m good now.


#5

There are mixed content warnings:

http:// gulfbreeze . com / files/wp-less/chicagoemail/style-1b02f8db76.css

is loaded per http, not per https.

Use FireFox or Chrome, Ctrl + Shift + I, then open the console, there are two errors.