My DNS takes 24 hours to update the txt files

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Heart Internet

I can login to a root shell on my machine - YES

I have loaded up 6 cet txt files, over a 48 hour period, but my ISP take a least 24 hours minimum to update the txt files in the DNS zone. I am unable to keep the ‘letsencrypt’ script paused for so a long time, and so I have to run the script agaain, but as the ‘letsencrpt’ creates a new code’ each time it runs… I am never going to be able to satisfy the requirments.

Is there another way that we can ‘ping’ to check that the TXT files are valid in my dns txt files ? because when i run the script again… it ignores the old ‘letsencrypt’ txt files…

How you other another way please

Best wishes

Hi @Percy

if your ISP is so slow, you should change.

But checking your domain, the wrong entries are created -

The first four entries are completely wrong.

Compare it with

The Domain name must start with _acme-challenge. And the TXT entry: There is no _acme-challenge.yourdomainname allowed.


Hi, Thank you… I understand now, I will correct

Thank you

Best wishes

Most DNS providers have issues that can affect LetsEncrypt validation. While I do not think 24hours is acceptable, a lot of similar issues can happen with shorter times. IMHO, changing a hosting provider will not necessarily fix an issue lie this.

It looks like the hosting provider is a subsidiary of a subsidiary of a subsidiary of a subsidiary of godaddy. There are a lot of customer support options to improve that DNS time.

However, if the OP is technically inclined, running acme-dns ( on a server is the best way to handle DNS challenges.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.