Missing/old python Version on Centos


#1

Hello,

I am trying to run letsencrypt on Rockstor, which is based on Centos.

Unfortunately, I get an Error related to the Python version:


Error: Package: tkinter-2.7.5-34.el7.x86_64 (base)
Requires: python = 2.7.5-34.el7
Installed: python-2.7.5-18.el7_1.1.x86_64 (@anaconda/3)
python = 2.7.5-18.el7_1.1
Error: Package: python-tools-2.7.5-34.el7.x86_64 (base)
Requires: python = 2.7.5-34.el7
Installed: python-2.7.5-18.el7_1.1.x86_64 (@anaconda/3)
python = 2.7.5-18.el7_1.1
You could try using --skip-broken to work around the problem

It seems, the Version 34.el7 is not available on Rockstor. Is there a way to work around this problem?

Regards,
Hendrik


#2

would other 3rd party YUM repos work i.e. IUS Community outlined at Redhat / CentOS 6.x users need python 2.7 ?


#3

Thanks Eva2000,

I am not sure…
The Thread you quoted explains how to install python2.7 on centos6. I am already using 2.7.5 though.
But letsencrypt complains, that I am not using “2.7.5-35”, but “2.7.5-18”

The thread you pointed me at mentions, that letsencrypt has python 2.6 support now aswell, so I am even more confused about the message.

Greetings,
Hendrik


#4

It looks like your distribution has some package inconsistencies or possibly you added some repositories that follow the CentOS7 or RHEL 7 package versions and not the custom fork you are using. I’d recommend first trying a full package update and if you don’t see any improvements, contact the distribution maintainers about the issue.


#5

Ok, thanks.

Greetings,
Hendrik