Mismatch pip - apt version certbot

Hi,

I have cerbot 1.12 installed from raspberian repo (debian 11 / bullseye, dir is /usr/bin/cerbot).
Due to the fact desec.io switched to authenticator dns-desec the setup recommended pip install of certbot (which is version 1.27)
The cert renew works fine with 1.27 (pip version), install directory /usr/local/bin/).

If I manually call certbot version 1.12 trying for dryrun I get:
pkg_resources.VersionConflict: (certbot 1.12.0 (/usr/lib/python3/dist-packages), Requirement.parse('certbot>=1.14.0'))

2022-06-05 15:56:43,989:DEBUG:certbot._internal.log:Exiting abnormally:
Traceback (most recent call last):
File "/usr/bin/certbot", line 33, in
sys.exit(load_entry_point('certbot==1.12.0', 'console_scripts', 'certbot')())
File "/usr/local/lib/python3.9/dist-packages/certbot/main.py", line 19, in main
return internal_main.main(cli_args)
File "/usr/local/lib/python3.9/dist-packages/certbot/_internal/main.py", line 1705, in main
plugins = plugins_disco.PluginsRegistry.find_all()
File "/usr/local/lib/python3.9/dist-packages/certbot/_internal/plugins/disco.py", line 241, in find_all
plugin_ep = cls._load_entry_point(entry_point, plugins, with_prefix=False)
File "/usr/local/lib/python3.9/dist-packages/certbot/_internal/plugins/disco.py", line 261, in _load_entry_point
plugin_ep = PluginEntryPoint(entry_point, with_prefix)
File "/usr/local/lib/python3.9/dist-packages/certbot/_internal/plugins/disco.py", line 60, in init
self.plugin_cls: Type[interfaces.Plugin] = entry_point.load()
File "/usr/lib/python3/dist-packages/pkg_resources/init.py", line 2449, in load
self.require(*args, **kwargs)
File "/usr/lib/python3/dist-packages/pkg_resources/init.py", line 2472, in require
items = working_set.resolve(reqs, env, installer, extras=self.extras)
File "/usr/lib/python3/dist-packages/pkg_resources/init.py", line 777, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.VersionConflict: (certbot 1.12.0 (/usr/lib/python3/dist-packages), Requirement.parse('certbot>=1.14.0'))
2022-06-05 15:56:43,990:ERROR:certbot._internal.log:An unexpected error occurred:
2022-06-05 15:56:43,992:ERROR:certbot._internal.log:pkg_resources.VersionConflict: (certbot 1.12.0 (/usr/lib/python3/dist-packages), Requirement.parse('certbot>=1.14.0')).

What is the best way either to

  • preserve possibility to use both in parallel
  • remove apt version 1.12 (removing via apt remove will also clean mandb entries)
  • leave it as it is
  • wait for official 1.14 to match version requirement again :wink:

Any help welcome.

Thanks,
Mike

Uninstall certbot from apt and use the pip version in a virtual environment. That's what I would do.

3 Likes

What do u mean with "virtual environment"?

Please see the Certbot pip installation instructions here: Certbot Instructions | Certbot

3 Likes