Migrating from sslforfree

That can’t work. Looks like Certbot waits to your input and you don’t see it.

If you want to create a wildcard certificate, dns-01 validation is required. So webroot can’t work.

How do I fulfill the requirement

Check

Do you really need a wildcard certificate?

You can always use --manual, but you must see the output. Certbot creates a txt entry.

You have to create two DNS TXT entries

_acme-challenge.kingbiscuitblues.com

with two different values. If you have more domain names, one value per domain name.

And normally it’s easier to create one certificate per domain (non-www + www), not one certificate with different main domain names.

sudo certbot certonly --manual --preferred-challenges dns -d *.kingbiscuitblues.com -d kingbiscuitblues.com

certbot: error: unrecognized arguments: certonly --manual

What says

certbot --version

Sorry I solved that last issue before success The --manual option wasn’t an unrecognized argument, it was a subargument to --manual that were wrongly syntaxed --preferred-challenges dns should be --preferred-challenges=dns In conclusion, having certbot installed on my server to help with ssl certificates is a big step up from doing it manually

If you want to create a wildcard certificate, you have to use dns-01 validation.

So the --preferred-challenges isn’t required.

–challenge dns-01 ?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.