Manual renewal skipped over new domain added


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: asystyoutech.com

I ran this command: sudo /opt/bitnami/ctlscript.sh stop

sudo /opt/bitnami/letsencrypt/lego --email="support@asystyou.com" --domains=“asystyoutech.com” --domains=“www.asystyoutech.com” --domains=“local.asystyoutech.com” --domains=“asystyoumarketing.com” --domains=“www.asystyoumarketing.com” --path="/opt/bitnami/letsencrypt/certificates" renew

This was to renew my original certificate and to add a new subdomain (local.asystyoutech.com) to the certificate. The renewal worked fine but the new subdomain was skipped.

My web server is (include version): Apache 2.4.37

The operating system my web server runs on is (include version): Linux Debian 4.9.0.8

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


#2

It doesn’t seem like Lego supports expanding certificates - https://github.com/xenolf/lego/issues/507#issuecomment-382858046

What you might need to do is delete the certificate and re-create it (using run instead of renew) with the extra subdomain.


#3

thanks _az. i was going to try delete and re-create as a next alternative. i think it’s time to make that change.