Manual-Mode Timeouts too early


#1

Hello,

I am trying to install a cert on an SLES11-Server with the Client Running on an Ubuntu-machine.
So far no luck.

I tried to start the client in manual mode.
./letsencrypt-auto certonly --manual

I entered the domain and agreed to the storage of my clients-ip-address.
Then on the SLES is created just as the client says the directory and the response file
and startet the python server (before that I stopped the installed apache)

Then I got the message

88.198.39.173 - - [02/Feb/2016 11:27:02] “GET /.well-known/acme-challenge/iIoTvDx1wWgcLkDRq13U_K1iYlUIrxQJ71yEfGW_WrI HTTP/1.1” 200 -

On the SLES machine, shortly after that the error message on the ubuntu machine
Failed authorization procedure. worklight.smarteco-system.com (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Could not connect to http://worklight.smarteco-system.com/.well-known/acme-challenge/iIoTvDx1wWgcLkDRq13U_K1iYlUIrxQJ71yEfGW_WrI

IMPORTANT NOTES:

Shortly after that the SLES machine reported another request for the well-known service. I expect this the letsencrypt server as the first request was from the ubuntu machine.

66.133.109.36 - - [02/Feb/2016 11:27:13] “GET /.well-known/acme-challenge/iIoTvDx1wWgcLkDRq13U_K1iYlUIrxQJ71yEfGW_WrI HTTP/1.1” 200 -

So it seems the client does not wait for the answer from the letsencrypt service. I am not that into python maybe someone can help me with increasing a timeout so the client will not fail that quick to wait for the response.

Thank you