Lost SSL because of typo in email address

My domain is: fibotech.ca & oten.top

I ran this command: “On install, I had a typo in my email.”

It produced this output: “This email is unacceptable”

My web server is (include version): UpCloud.com

The operating system my web server runs on is (include version): Ubuntu

Do I have to wait a week and try again?

With this little information I’m guessing the answer is “No”. The one week period is mostly associated with the rate limits when you’re getting too much certificates. But as far as I can reproduce from your post you’re not getting any certificate.

But without knowing exactly what you did and what the responses were, it’s hard to know. You’ve deleted much of the questionnaire. You shouldn’t have done that.

Hi Osiris, I am using upcloud.com and following the instructions from https://upcloud.com/community/tutorials/set-up-multiple-wordpress-easyengine/

I was able to have my sites fibotech.ca and oten.top on SSL but I had to delete the cloud server because of configuration issues. When I went to re-install Wordpress with SSL, I accidentally typed " instead of @ for the email registration with LE and now I get “This email is unacceptable” and no chance to correct the email.

Hope this explain my issue more, thank you

This isn’t a specific Let’s Encrypt issue, but an EasyEngine issue.

Fortunately, I’m pretty sure a solution can be found quickly. And when I say quickly, I mean quickly, like, within 5 minutes.

Using the keywords “ee site update email” on Google, I came across the following EasyEngine help page:

It explains the ee site update command and it includes the --le-mail option. Please try that. You might want to try ee site list first to see what EasyEngine has configured for that site.

2 Likes

I went ahead and delete the setup and re-install to show the output here:

usff@ubuntu-1cpu-1gb-us-chi1:/$ sudo ee site delete fibotech.ca
Are you sure you want to delete fibotech.ca? [y/n] y
[fibotech.ca] Docker Containers removed.
[fibotech.ca] site root removed.
Removed database entry.
Site fibotech.ca deleted.
usff@ubuntu-1cpu-1gb-us-chi1:/$ sudo ee site create fibotech.ca --type=wp --ssl=le --cache
Starting site creation.
Configuring project.
Creating WordPress site fibotech.ca
Copying configuration files.
Starting site's services.
Downloading and configuring WordPress.
Moved /var/www/htdocs/wp-config.php to /var/www/wp-config.php successfully
Checking and verifying site-up status. This may take some time.

Installing WordPress site.
Success: https://fibotech.ca has been created successfully!
Warning: It seems you're in local environment or used invalid email or there is some issue with network, please check logs. Skipping letsencrypt.
Warning: [invalidEmail] This email is unacceptable (e.g., it is invalid): Error creating new account :: "...myemailsuffix...\"gmail.com" is not a valid e-mail address (on request "POST https://acme-v02.api.letsencrypt.org/acme/new-acct")
Warning: Initiating clean-up.
[fibotech.ca] Docker Containers removed.
[fibotech.ca] site root removed.
Site fibotech.ca deleted.
usff@ubuntu-1cpu-1gb-us-chi1:/$ 

Your suggestion worked. Thank you. I have to make changes to my TXT record for propagation to complete now.

Output from new install:

Add the following TXT record to your DNS zone
Domain: _acme-challenge.fibotech.ca.
TXT value: y5BxAsyGdt_m_6OFpoMwdwfQFPZcyx_7hi6sGWFLpX8

Wait for the propagation before moving to the next step
Tips: Use the following command to check the propagation

    host -t TXT _acme-challenge.fibotech.ca.

Add the following TXT record to your DNS zone
    Domain: _acme-challenge.fibotech.ca.
    TXT value: -yzeAIiDouqyl6Q09euHgOFKmoDJ8IihsW2_tb8Ih00
    
Wait for the propagation before moving to the next step
Tips: Use the following command to check the propagation

    host -t TXT _acme-challenge.fibotech.ca.

IMPORTANT: Run ee site ssl fibotech.ca once the DNS changes have propagated to complete the certification generation and installation.Starting site’s services.

Success: Enabled ssl for fibotech.ca

Thanks again for the assistance. I appreciate it.

2 Likes

Doesn’t EasyEngine have a way to automate that? Because otherwise you’d have to do that every time the certificate nears the expire date and the certificates are only 90 days valid. Let’s Encrypt recommends to renew the certificate 30 days before expiry (i.e. every 60 days).

Edit:
Hmm, this only seems to be the case when you have CloudFlare as DNS service:

Other automated DNS integrations aren’t possible it seems unfortunately.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.