Listed Domains Do Not Point to Server

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: certbot --apache

It produced this output: Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
Type: unauthorized
Detail: Invalid response from []: "\r\n\r\n\r\n \r\n 404 Error - Page Not Found\r\n \r\n #ad_frame"

Hint: The Certificate Authority failed to verify the temporary Apache configuration changes made by Certbot. Ensure that the listed domains point to this Apache server and that it is accessible from the internet.

Cleaning up challenges
Some challenges have failed.
Ask for help or search for solutions at See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version): 2.4.41

The operating system my web server runs on is (include version): Ubuntu 20.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.24.0.dev0

1 Like and point to different IP addresses.

Which one is correct? Which server are you running Certbot on?


I've successfully installed the cert and run certbot on I would like to point to the same server. Is that a problem that could be addressed by adding a DNS record? If not, then what?

1 Like

Yes, it can. You should login in your DNS provider panel ( and add/edit a record (A and/or AAAA) for the www subdomain, pointing to the same IP address as, which might be referred to as @.


Thank you. I tried it and it worked!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.