LetsEncypt TXT record validation is not working

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: stage.wideroe.no

I ran this command: lets_encrypt r stage.wideroe.no

It produced this output:

+----------------------------------+--------+
| Domain                           | Status |
+----------------------------------+--------+
| _acme-challenge.stage.wideroe.no |        |
+----------------------------------+--------+

My web server is (include version): MacOs Mojave 10.14.6

The operating system my web server runs on is (include version): don’t know

My hosting provider, if applicable, is: customer domain not owned by me

I can login to a root shell on my machine (yes or no, or I don’t know): i’m root on the machine (local)

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): n/a

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): don’t know

Problem: although the txt record is publically available for this domain:
_acme-challenge.stage.wideroe.no. 236 IN TXT "04Js_RxitzRZ_U0aCRAZXvCPqyReTyKArbggBuKv0vU"

I’m still not getting the validation and hence not getting the certificate created.

Any help will be appreciated, thanks in advance.

Hi @tmansoor

checking your domain you have created the correct TXT entry - https://check-your-website.server-daten.de/?q=stage.wideroe.no#txt

The correct domain name and a good-looking entry.

But:

Never seen that client. Is there a better log? A detailed error message why the certificate creation doesn’t work?

PS: Unboundtest

https://unboundtest.com/m/TXT/_acme-challenge.stage.wideroe.no/2PUPRVAT

is happy too. Letsencrypt uses an unbound instance with the same configuration, so Letsencrypt should be able to find your TXT entry.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.