LetsEncrypt SSL not working with Facebook and Google login on Discourse


#1

My programmer installed the SSL on my discourse site https://forum.domadoma.sk/ Everything looks fine in browser, but once I try set up the Facebook login or Google login, I still get the error messages, Insecure Login Blocked: You can’t get an access token or log in to this app from an insecure page. Try re-loading the page as https://

Thank you for helping me out.


#2

Nothing is wrong with the certificate, you need to configure your Discourse and Google/Facebook apps to point to the correct URL with the correct scheme (http/https).


#3

everything pointing to the https https://prnt.sc/ixeg3q and I am still getting the security isssue,

in google app the URL is pointing to the right https:// and giving me error URL with just http://


#4

Hi,

This means that your OAUTH URL set in Google API OAUTH screen is not match to the url you are trying to use as OAUTH.

You’ll need to update that from your Google Cloud Console.

THIS HAS NOTHING TO DO WITH LETS ENCRYPT.
THIS IS A MISCONFIGURATION OF YOUR DISCOURSE INSTALLATION.

Thank you


#5

Setting the right URL in the API Console is necessary, but not sufficient to get the right URL working. The redirect_url is sent by Discourse itself when redirecting users to the Google login page; the console only stores a list of valid destinations.

This thread on the Discourse meta suggests that when Discourse sends http instead of https to third-party login providers it is because your proxy setup prevents Discourse from realizing it is running on HTTPS. A few workarounds are described:

If you continue to have trouble please ask for further assistance on the Discourse Meta as they seem to be familiar with this class of problem.


#6

That is exactly what was happening and what was the problem. Thank you for pointing me to the right solution.


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.