Letsencrypt renew error: failure

Performed the following command on my server sudo letsencrypt renew and got the following error:

Attempting to renew cert (athena,thecpigroup.com) from /etc/letsencrypt/renewal/athena.thecpigroup.conf produced and unexpected error: Failed authorization procedure. athena.thecpigroup.com (http-01): urn:left:params:acme:error:unathorized :: The client lacks sufficient authorization :: 47.207.11.13: Invalid response from http://athena.thecpigroup.com/.well-known/acme-challenge/i3qdZOEfKHMuTSZZdOBmEUuVuZ5WU8QmOeuJ26sCFyO: 404

Running ubuntu 18.04 nginx services

Also tried the following command:
sudo letsencrypt --force-renew -d athena.thecpigroup.com

Recieved the following error:

Domain: athena.thecpigroup.com
Type: unathorized
Detail: 47.207.11.13: Invalid response from http://athena.thecpigroup.com/.well-know/acme-challenge/6G3kDUTn_qtpuWK8sNdsuiKLxwfYpiq8783LjHH1y04: 404
UPDATE

No longer getting the unauthorized lacks sufficient authorization now I am receiving the follow:

Type: Connection - fetching; Timeout during connect

Please Help

Hi @walter28, and welcome to the LE community forum :slight_smile:

Using force hardly ever does what you seem to expect: Make a broken system work.

Something is not working.
Let's review the Apache settings with the output of:
apachectl -t -D DUMP_VHOSTS

FYI: Apache responds not nginx

This is what responds:

curl -Ii athena.thecpigroup.com
HTTP/1.1 200 OK
Date: Fri, 13 May 2022 21:34:23 GMT
Server: Apache/2.4.41 (Ubuntu)
1 Like

I tried running the apachectl -t -D DUMP_VHOSTS on my server and got the following:

-bash: apachectl: command not found

Then you need to follow the packet.
Where does 47.207.11.13:80 end up?

1 Like