Letsencrypt client keeps using staging on renew


#1

Please fill out the fields below so we can help you better.

My domain is: planhet.nu

I ran this command: letsencrypt renew --force-renew -vvv or letsencrypt renew --force-renew --break-my-certs -vvv

It produced this output: Congratulations, all renewals succeeded. The following certs have been renewed:
/etc/letsencrypt/live/planhet.nu/fullchain.pem (success)
2017-04-13 21:49:42,479:DEBUG:letsencrypt.cli:no renewal failures

My operating system is (include version): Ubuntu (16)

My web server is (include version): nginx, The nginx server is used as a proxy to a meteor application.

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

=======================================
I had some problems today with the automatic renewal of my certificate. So i decided to use the staging server with the --staging option to figure things out.

However now the original problem is solved and a renewed certificate is used, the certficate is isued by: Fake LE Intermediate X1.
The verbose output also shows that the staging endpoint : https://acme-staging.api.letsencrypt.org/acme/authz/ is still used.

Could someone tell me how i could force the letsencrypt api to use the production api once again. As my application is currently unavailable.

Thanks in advance !


#2

hi @timjong93

From the manual: https://certbot.eff.org/docs/using.html

–break-my-certs Be willing to replace or renew valid certs with
invalid (testing/staging) certs (default: False)

Not sure why you are using that switch?

Andrei


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.