Letsencrypt certonly error the provider email for registration was invalid


#1

Please fill out the fields below so we can help you better.

My domain is: t.acumenholdings.co.za, www.t.acumenholdings.co.za

I ran this command: letsencrypt certonly --webroot -w /var/www/letsencrypt -d www.t.acumenholdings.co.za -d t.acumenholdings.co.za --email stuart@acumenholdings.co.za --agree-tos

It produced this output:letsencrypt certonly error the provider email for registration was invalid :: could not connect to (both domains). But had email error and .well-known not reachable, but have keys in /etc/letsencrypt for the sites

My operating system is (include version): ubuntu 16.04 running

My web server is (include version):nginx 1.10.0

My hosting provider, if applicable, is:webafrica

I can login to a root shell on my machine (yes or no, or I don’t know):YES

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):cpanal


#2

also made sure to
chown -R www-data:www-data /var/www/letsencrypt/
chmod 777 /var/www/letsencrypt/
.well-known exist in here, if I try running them on /var/www/letsencrypt/.wellknown I get an error ‘no such file or directory’ but it’s there.
running the setup according to https://gist.github.com/cecilemuller/a26737699a7e70a7093d4dc115915de8
Tried a few others but all had problems, will be doing certs for the same server but learn.acumenholdings.co.za for our moodle box if I can crack this. But now I’m ratelimeted, too many attempts


#3

Ok, sorted this one, was the slow dns issue for the email but also an error introduced to a config thanks to echo and putty doing somthing strange. the https://gist.github.com/cecilemuller/a26737699a7e70a7093d4dc115915de8 is good for ubuntu 16.04 with nginx untill ubuntu update there repositry with the certbot that works so nice with nginx. cheers
:slight_smile:


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.