Letsencrypt and humhub certs issue problem

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: localhost–>so no domain

I ran this command: sudo certbot certonly --standalone -d temp.humhub.dev

It produced this output:

My web server is (include version): Server version: Apache/2.4.41 (Ubuntu)
Server built: 2019-08-14T14:36:32

The operating system my web server runs on is (include version): ubuntu 19.04 5.3.0-62-generic

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

What do you mean by this? You are not running Certbot on the same server where temp.humhub.dev is hosted?

apologize for my little knowledge here…
im running apache2 on localhost, and i need to install a app for testing and on the manual is reporterd just:


Install Certbot and obtain SSL certificates for the portal.

apt install certbot

certbot certonly --standalone -d temp.humhub.dev

and in the sites aviable conf there is:

SSLEngine on
SSLCertificateFile /etc/letsencrypt/live/temp.humhub.dev/cert.pem
SSLCertificateKeyFile /etc/letsencrypt/live/temp.humhub.dev/privkey.pem
SSLCertificateChainFile /etc/letsencrypt/live/temp.humhub.dev/fullchain.pem

but if i run the suggested command i rise the above error…how can go on? thanks


Let’s Encrypt won’t just hand out a certificate for a domain you don’t control. As such, the only way these instructions would work for you is if you had your own domain, and a publicly accessible webserver to which that domain points.

In cases like these, where you’re just doing something locally, it might be better to generate a certificate using a tool like mkcert.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.