"Let's Encrypt" setup doesn't complete successfully



I’m trying to run ./letsencrypt-auto but I get the following message:

No package python27 available.
No package python27-devel available.
No package python27-virtualenv available.
Error: Nothing to do
Could not install Python dependencies. Aborting bootstrap!

*Server OS is: CentOs 7.1

I want to emphasize that the server is a production server, and the current python version is 2.7.5
I don’t want to override any service, it can harm the application service.



There are various other LE client implementations that you can use if you can’t use the default python one.