Lets encrypt redirecting my domain


#1

I currently ran lets encrypt on ssh on a domain and it asked me if I wanted to forward all traffic on that domains to https. I ran two domains at the same time and now it’s forward traffic from domain1.com to domain2.com. I can’t figure out where that’s being done. Is there a file it wrote to?


#2

Yes, you might find the details in the letsencrypt.log file.
Or just look through your http vhost configs.


#3

Hi @impactcolor

is it a redirect? Or does the second domain use the wrong certificate?

Share your domain names and your VirtualHost - Files.


#4

tracker.cityloccsblog.com is forwarding to options.citylocsblog.com
The http.conf file has nothing saying that it’s forwarding. Where else could I check?


#5

The first domain name doesn’t have any DNS entries ( https://check-your-website.server-daten.de/?q=tracker.cityloccsblog.com ), the domain name isn’t defined.

Host T IP-Address is auth. ∑ Queries ∑ Timeout
tracker.cityloccsblog.com Name Error yes 1 0
www.tracker.cityloccsblog.com Name Error yes 1 0

So this isn’t a domain with a normal redirect (http status 301 or 302).

So nobody can load tracker.cityloccsblog.com, because the browser can’t find an ip address.


#6

Sorry I made a mistake and added an extra c
It’s
tracker.citylocsblog.com


#7

I see, you have already checked the domain via https://check-your-website.server-daten.de/?q=tracker.citylocsblog.com :

Now there is a redirect:

Domainname Http-Status redirect Sec. G
http://tracker.citylocsblog.com/
132.148.156.234 301 https://tracker.citylocsblog.com/ 0.317 A
https://tracker.citylocsblog.com/
132.148.156.234 302 https://tracker.citylocsblog.com/authenticate? 2.834 N
Certificate error: RemoteCertificateNameMismatch
https://tracker.citylocsblog.com/authenticate? 302 https://tracker.citylocsblog.com/login 2.646 N
Certificate error: RemoteCertificateNameMismatch
https://tracker.citylocsblog.com/login 200 2.670 N
Certificate error: RemoteCertificateNameMismatch

http redirects to https, but https doesn’t has a valide certificate and redirects to /authenticate, then to login.

So it doesn’t work as a tracker.


#8

PS: Your certificate tracker uses has two entries:

CN=options.citylocsblog.com
	28.12.2018
	29.03.2019
	options.citylocsblog.com, www.options.citylocsblog.com - 2 entries

So perhaps create one certificate with three domain names and use that.

The tool ignores certificate errors, but a browser would block, so no redirect would be done.


#9

I tried to redo another certificate for just tracker but that didn’t work either. Is there anyway I could disable the https on tracker?


#10

If you create only http links and if you remove the redirect http -> https, you could to that.

But then browsers may block that, because it’s mixed content. So the tracker wouldn’t work.

Checked your main domain:

CN=citylocsblog.com
	08.02.2019
	10.05.2019
	citylocsblog.com, cpanel.citylocsblog.com, 
mail.citylocsblog.com, webdisk.citylocsblog.com, 
webmail.citylocsblog.com, www.citylocsblog.com - 6 entries

there is a cPanel-certificate.

Is this the same server?

And your tracker-certificate is a cPanel-certificate too. So it should work to create a certificate with the correct domain name.


#11

Yes it’s the same domain. tracker is a subdomain.
Ok I’ll try that. THANK YOU!