Lets Encrypt Changes Have KIlled My Nextcloud Server

#1

Ever since the changes to let’s encrypt earlier this month my nextcloud instance has ground to a halt. To be honest a 56k modem would run faster. The server has always run fine before the authentication changes. Has anyone else had this issue could someone please advise?

My domain is: https://cloud.geekgalaxy.com/nextcloud

I ran this command:

It produced this output:

My web server is (include version): Apeche2 running Nextcloud 15

The operating system my web server runs on is (include version): Ubuntu 18.10

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.28.0

#2

Hi @felthamn1,

It’s probably not any changes to Let’s Encrypt, since the software that runs on your server runs only rarely, and doesn’t consume a lot of resources. Is it possible you made some config changes recently?

If you run top, do you see any processes using a lot of CPU? What are the specific actions that became slower?

#3

Nothing untoward with regards to CPU usage. Loading the login page takes an age. I’m using noIP enhance for dynamic DNS. It’s almost as if my connection is being throttled going to check the ratelimit

#4

Hi @felthamn1

I’ve checked the login page, it wasn’t slow.

Same with Chrome and FireFox.

Are you sure it isn’t a connection problem?

1 Like
#5

Okay, that’s reassuring will try a different browser will also reboot the modem. Thanks for checking will report back.

1 Like
#6

If restarting doesn’t help, one thing you can try is enabling OCSP Stapling on your web server, so that your browser does not need to connect to the Let’s Encrypt OCSP server independently. I’ve seen that cause similar symptoms before.

Something like:

# OCSP Stapling, only in httpd 2.3.3 and later
SSLUseStapling          on
SSLStaplingResponderTimeout 5
SSLStaplingReturnResponderErrors off
SSLStaplingCache        shmcb:/var/run/ocsp(128000)

The other thing is lowering either your computer’s MTU to ~1300 and see if that helps as well.

1 Like
#7

Hi @JuergenAuer

Well… rebooted the router after checking the QoS settings. Reset them to standard and changed the DNS away from my pi-hole ad-blocker and the pages are loading superfast. So will change the DNS back to pi-hole to see if it slows things down. If it doesn’t slow things down then I can only assume someone (i.e. me!) must have changed the QoS to the point where it wasn’t playing nicely with nextcloud.

3 Likes
#8

@_az

Thanks for the tip will keep that at hand just in case…

closed #9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.