Let's Encrypt can't seem to resolve my domain

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: coin.hellomouse.cf (please ignore the invalid cert, I know it’s for another domain; it shouldn’t affect the issue)

I ran this command: certbot certonly

It produced this output: … please see problem description below

My web server is (include version): nginx/1.10.3

The operating system my web server runs on is (include version): Alpine Linux 3.5 kernel version 4.10.17 x86_64

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

Problem description: I am trying to use certbot to obtain a certificate for coin.hellomouse.cf but am running into the issue that, apparently, “No valid IP addresses found for coin.hellomouse.cf”. I tried using Google’s public DNS resolver, nslookup directly to the server, and some other random “dns propogation checkers”, and all of them resolve the domain correctly.

There is a custom nameserver running on the domain, so I can understand why there might be issues. However, I’m curious as to why other DNS resolvers don’t report any issues, but the Let’s Encrypt one seems to fail. Perhaps this is an issue with my resolver?

The custom nameserver works properly, as I can generate certificates using DNS challenges.

Aha! Found it by checking logs… the server was resolving records in a case-sensitive manner, and Let’s Encrypt was sending the records with a weird case.

For those who use Let’s Encrypt in the future and have issues - fun fact! Let’s Encrypt messes with caps :slight_smile: Make sure your DNS server is case-insensitive…

This is because of this:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.