Lets Encrypt based Certificate based out of Route53 is failing

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: *.ilabx.com

I ran this command: certbot certonly --manual --preferred-challenges=dns --email deepanshu.chamoli@agilent.com --server https://acme-v02.api.letsencrypt.org/directory --agree-tos -d catalog-production.ilabx.com

It produced this output: Generate certificates

My web server is (include version): Proxy Server

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Hi There -

I am using Encrypt acme_challenge for about 2 years and it works. Recently I moved my Domain to Route53. Today when I tried to renew Certs via certboot it works and I got the certs. However, when I applied the Certs to Proxy Server sites are down with Connection timeout and No SSL Certificate.

Please suggest where is the miss. Thanks!!

Hi @DeepanshuChamoli, and welcome to the LE community forum :slight_smile:

Please show the code where you applied the cert
and the output of: certbot certificates

There's probably nothing wrong with the certificates themselves.

@DeepanshuChamoli Could you please share what's not working exactly? https://catalog-production.ilabx.com/ (from your certbot command) is working perfectly and https://www.ilabx.com/ does not give a connection time out, but a secure 502 bad gateway error (which is not Let's Encrypt related).

So as far as I can see, I'm just seeing working sites or non-Let's Encrypt related misconfigured webservers..

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.