Issues with Updating just one URL from all he sites we have? HELP :/


#1

Hello guys,

I hope someone can help me with this, the Certificate will expire tomorrow :confused:

Here is the Response I get when Trying to update the certificate: ( I have replaced actual paths to protect the identity of the site. )

Authorizing Identifier [MY SITE] Using Challenge Type http-01
Writing challenge answer to C:\inetpub[PATH].well-known/acme-challenge/YqIsJX3Vbj_OWGdRGUPpWQdLRvaM0V6xTFovw-U6cys
Writing web.config to add extensionless mime type to C:\inetpub[PATH].well-known\acme-challenge\web.config
Answer should now be browsable at http://[PATH]/.well-known/acme-challenge/YqIsJX3Vbj_OWGdRGUPpWQdLRvaM0V6xTFovw-U6cys
Submitting answer
Refreshing authorization
Authorization Result: invalid
Authorization Failed invalid


The ACME server was probably unable to reach http://[PATH]/.well-known/acme-challenge/YqIsJX3Vbj_OWGdRGUPpWQdLRvaM0V6xTFovw-U6cys

Check in a browser to see if the answer file is being served correctly.
Authorize failed: This could be caused by IIS not being setup to handle extensionless static files.Here’s how to fix that:
1.In IIS manager goto Site/ Server->Handler Mappings->View Ordered List
2.Move the StaticFile mapping above the ExtensionlessUrlHandler mappings. (like this http://i.stack.imgur.com/nkvrL.png)
3.If you need to make changes to your web.config file, update the one at C:\inetpub\letsencrypt\web_config.xml


I have the steps 1,2,3 but it’s still not working regardless and I can access the URL provided with a response correctly.

Thanks,
Marco Beaulieu


#2

to protect the identity of the site

This makes it too hard for anybody trying to help you. There are many potential issues that can only be known if we know your domain name (such as AAAA records, DNSSEC etc).

Please provide the real domain name, as well as a test URL pointing to a static file.


#3

Hi Marco

When you create a help topic you are asked a bunch of questions and as @_az mentioned the domain name

it’s best to stick to that format so others can help. None of the information currently provided is coherent or can be used to assist.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#4

Does that ACME client log the error message from Let’s Encrypt? Or the authz URL so the error message can be checked?


#5

Problem fixed, it was actually us that caused the issues, we have setup IP limits to that server, so Let’s Encrypts what not capable of hitting the URL for validation.

Thanks for the Response guys.

Marco Beaulieu


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.