Issue with renewal

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: Fidgi Communications

I ran this command: certbot --apache -d

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Cert is due for renewal, auto-renewing...
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for
Waiting for verification...
Challenge failed for domain
http-01 challenge for
Cleaning up challenges
Some challenges have failed.


  • The following errors were reported by the server:

    Type: connection
    Detail: Fetching
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you're using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version): Apache HTTP Server 2.4.41

The operating system my web server runs on is (include version): Ubuntu 20.04.4 LTS

My hosting provider, if applicable, is: Digital ocean

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.40.0

Hi @mmazraani and welcome to the community!
Your error response says LE Servers are trying to connect to your server on port 80 (http)
When checking your IP it looks like port 80 is being "filtered" and therefore is is not allowing LetsEncrypt to validate your system.

Have a look at this information:

Open up port 80 (http) and give it another go!


Weird because port 80 seems to be opened:

To Action From

22/tcp LIMIT Anywhere
Apache Full ALLOW Anywhere
443/tcp ALLOW Anywhere
80/tcp ALLOW Anywhere
22/tcp (v6) LIMIT Anywhere (v6)
Apache Full (v6) ALLOW Anywhere (v6)
443/tcp (v6) ALLOW Anywhere (v6)
80/tcp (v6) ALLOW Anywhere (v6)

Something is blocking HTTP requests. Are there any firewall or similar settings in D/O? I can see your site using HTTPS but not HTTP

What does your Apache look like:

sudo apachectl -t -D DUMP_VHOSTS

I get this:

AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using Set the 'ServerName' directive globally to suppress this message
VirtualHost configuration:
*:443 is a NameVirtualHost
default server (/etc/apache2/sites-enabled/000-default-le-ssl.conf:2)
port 443 namevhost (/etc/apache2/sites-enabled/000-default-le-ssl.conf:2)
port 443 namevhost (/etc/apache2/sites-enabled/
*:80 is a NameVirtualHost
default server (/etc/apache2/sites-enabled/000-default.conf:1)
port 80 namevhost (/etc/apache2/sites-enabled/000-default.conf:1)
port 80 namevhost (/etc/apache2/sites-enabled/

Apache is shown bound to port 80.
But it is not answering to the name "" directly on port 80.

The main problem is getting to port 80 from the Internet.
[likely blocked by your ISP]


The server's ISP correct?

1 Like

The ISP of


Those servers are hosted by digital ocean I assume I would need to check this with them.


I would say that is a fair assessment.


Thanks let's see what they got to say.


Digital Ocean is primarily a self-serve VPS provider. In case they cannot provide sufficient detail, here are some DO guides that pertain to both the firewall running in your Droplet's operating system and the DO Cloud Firewall.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.