Issue with certificate using cert-manager Kubernetes

My domain is:

I ran this command: created certificate using cert-manager on Kubernetes. ACME server URL:

It produced this output: Previously I had done this for the same domain on a different cluster and all worked fine. I had to destroy that cluster and create a new one. When I went through the process of acquiring a new certificate, it seems like the request was made successfully, but nothing has been issued. That was over 10 hours ago
Last Transition Time: 2020-03-29T21:20:10Z
Message: Waiting for CertificateRequest “xxxxxxx-916548373” to complete
Reason: InProgress
Status: False

My web server is (include version): php:7.2-fpm docker image running on Managed Kubernetes Version 1.16.6-do.2

The operating system my web server runs on is (include version): Debian 10 Buster

My hosting provider, if applicable, is: Digitalocean

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

What do the other resources say? e.g.

kubectl describe certificaterequest webcodelock-tls-916548373

I can’t remember whether it’s certificaterequest or order or challenge or whatever, but one of them has pretty detailed information on what’s happening.

e: Some helpful commands on

Found the issue. Was my own foolishness.

In my ingress yaml file I had domains defined that were no longer pointing to active servers so the certificate requests were failing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.