Invalid response from

My domain is: drcold.pro

I ran this command: sudo certbot certonly --manual -d drcold.pro -d www.drcold.pro -m coldje@msn.com

It produced this output: Waiting for verification...
Challenge failed for domain drcold.pro
Challenge failed for domain www.drcold.pro
http-01 challenge for drcold.pro
http-01 challenge for www.drcold.pro
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

My web server is (include version): Apache in XAMPP 7.4.11-0

The operating system my web server runs on is (include version): Ubuntu server 20.04 LTS

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No. Phpmyadmin yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): cerbot 0.40.0

My ISP is Spectrum over DOCSIS. My router is a Netgear Nighthawk X6 R8000. I am port forwarding ports 80 and 443 from my ISP's DHCP assigned address 75.176.52.45 to my server 192.168.1.4.
Wordpress works at http://drcold.pro as well as Moodle at http://drcold.pro/moodle.

I checked and no certificates have been issued.

1 Like

Welcome to the Let's Encrypt Community, Dr Cold :slightly_smiling_face:

Let's see here... :thinking:

You're trying to use manual authentication, which means you would need to create the authentication file by hand or with a script (or hook).

Could you try this for me, please:
sudo certbot run --cert-name drcold.pro --apache -d "drcold.pro,www.drcold.pro"

This may not work due to your Apache being in XAMPP, in which case I have another plan...

First, cleanup:
sudo certbot rollback

Then try this in alternative:
sudo certbot certonly --cert-name drcold.pro --webroot -w /opt/lampp/htdocs -d "drcold.pro,www.drcold.pro" --deploy-hook "sudo /opt/lampp/lampp reloadapache"

You'll need to modify your Apache configuration a bit at this point to serve the correct certificate.

1 Like

You were spot on correct. The first command came back with:
The requested apache plugin does not appear to be installed

The second command worked perfectly:
IMPORTANT NOTES:

  • Congratulations! Your certificate and chain have been saved at: ...

Specifying the webroot was something I hadn't tried before. Thank you very much.

2 Likes

Fantastic! :smiley:


Now you need to serve your certificate...

I believe that the file you want to edit is:
/opt/lampp/apache/conf/extra/httpd-ssl.conf

You can hopefully edit it using:
sudo nano /opt/lampp/apache/conf/extra/httpd-ssl.conf

For now though, to not work blind, please run the following two commands and paste the results in a post with three backticks (```) on separate lines above and below each output:

sudo httpd -S

sudo cat /opt/lampp/apache/conf/extra/httpd-ssl.conf

1 Like