Invalid response(404) with certonly

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

$ sudo certbot certonly -d
Saving debug log to /var/log/letsencrypt/letsencrypt.log

How would you like to authenticate with the ACME CA?

1: Apache Web Server plugin (apache)
2: Spin up a temporary webserver (standalone)
3: Place files in webroot directory (webroot)

Select the appropriate number [1-3] then [enter] (press 'c' to cancel): 1
Plugins selected: Authenticator apache, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
Enabled Apache rewrite module
Waiting for verification...
Challenge failed for domain
http-01 challenge for
Cleaning up challenges
Some challenges have failed.


  • The following errors were reported by the server:

    Type: unauthorized
    Detail: Invalid response from
    []: "\n<html
    style="height:100%">\n\n<meta name="viewport"
    content="width=device-width, initial-scale=1, shrink-to-"

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address.

My web server is (include version): Apache/2.4.46 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 20.10

My hosting provider, if applicable, is: Elixirnode? I'm running this on a RaspPi 4

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.7.0

Sorry, I do hope someone is able to help me. I previously used Certbot on a Windows system and am now trying to renew on Ubuntu. I also tried some of the third party tools and didn't seem to get anywhere.

Thank you in advance.

Hi @Jayms

reading your check, some hours old -

There runs a Litespeed, not an Apache. So the Apache plugin may not work.

May be try to use webroot.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.