Internal Error on Setting up Proxy Host

My domain is:

I ran this command: Add Proxy Host

It produced this output: Internal Error

My web server is (include version): Open Media Vault, (Version v3)

The operating system my web server runs on is (include version): Raspberry Pi 4 Model B 4GB Ram

My hosting provider, if applicable, is: Namechep

I can login to a root shell on my machine (yes or no, or I don't know): I don't know

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Portainer

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Error Message after trying to add SSL Certificate:

Error: Command failed: certbot certonly --non-interactive --config "/etc/letsencrypt.ini" --cert-name "npm-4" --agree-tos --email "" --preferred-challenges "dns,http" --domains ""
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Some challenges have failed.
Ask for help or search for solutions at See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

at ChildProcess.exithandler (node:child_process:326:12)
at ChildProcess.emit (node:events:369:20)
at maybeClose (node:internal/child_process:1067:16)
at Process.ChildProcess._handle.onexit (node:internal/child_process:301:5)

Pleaslet someone kind review the details and advice me on what to do to solve these issues.

Thanks in advance for your anticipated kind assistance.



Welcome to the Let's Encrypt Community, Kings :slightly_smiling_face:

We'll do our best to help. Please post the entire output of certbot with your email address removed in the output.

Also, please post the output of:

sudo certbot --version


Hi, thanks a lot for your prompt response, but honestly I do not know how to get the output of sudo certbot --version you are asking for.

I will appreciate if you could kindly guide me on how to get it.



How were you able to run the certbot command you posted?


@griffin My guess is Open Media Vault probably has some kind of "Get a certificate" button and uses certbot as the ACME client internally.

@ekings Not every one here on this Community is familiar with Open Media Vault. Could you perhaps tell us more about how you tried to add the SSL certificate? Was that part of the "Add Proxy Host" process? What does that "Add Proxy Host" actually do? Or did you press some other SSL related button?


You have a good point, @Osiris.


Are you presented any additional error output? The more complete, the better.


The strange thing is: when I check the source code of Open Media Vault and search for "certbot" in the code, I'm getting zero results..

Also, I'm seeing some NodeJS related things: "node:internal/child_process" in the error message and "npm-4" as "--cert-name" in the certbot command line. I see Open Media Vault uses npm for some things.. Maybe Open Media Vault uses some kind of NodeJS plugin to handle certbot? I'm just not sure...

I'm also pretty much afraid chances are this Community is not going to be able to debug this issue properly. Yes, we have much experience with certbot, but chances are there are SO many layers above the certbot command, we won't be able to help. Therefore, my recommendation is to also post your issue with as much information as possible on the Open Media Vault forum, which can be found here:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.