Installing Lets encrypt

I ran this command:
I ran the generated Runbook
It produced this output:
At line:127 char:14

  • $myCredential�= Get-AutomationPSCredential -Name�$Credential
  • ~~ Unexpected token ‘�=’ in expression or statement.

At line:130 char:16

  • $mysubscription�= (Get-AzureRmContext).Subscription.Id
  • ~~ Unexpected token ‘�=’ in expression or statement.

At line:131 char:10

  • $mytenant�= (Get-AzureRmContext).Subscription.TenantId
  • ~~ Unexpected token ‘�=’ in expression or statement.
    My web server is (include version):

The operating system my web server runs on is (include version):
My hosting provider, if applicable, is:

I set this up as a test before i move the site across to azure. I am using the word press for Linux azure app. I then followed the steps in “” and when running the runbook it issues that output in the exceptions.
This is step 3.4

So, first, I know absolutely nothing about working in Azure, but I am a bit concerned that you’re clearly executing PowerShell scripts, but you say you’re running a Linux server. I don’t see how that’s going to work.

I think the way it works is that power shell runbooks are run on azure. But i could be wrong

Azure supports either Windows or Linux instances, but as with @jared.m’s concern, I find it unlikely that you could run PowerShell scripts if you’re running on a Linux instance (although supposedly PowerShell has been ported to Linux, I would be surprised if it were available by default).

(Edit: However, I don’t know what a “runbook” is and perhaps Azure has some way to use PowerShell to automate administrative tasks even for Linux instances.)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.