Installing Client


#1

Hi,

I just tried to install the Lets Encrypt client.
I followed the instructions at https://letsencrypt.readthedocs.org/en/latest/using.html ,
but how can I run the client?

sudo ./venv/bin/letsencrypt auth
for example doesnt work because there ist no /venv dirchtory.

Where is the client stored?

Thanks


#2

Did you use Docker and the Quick Start instructions?


#3

Here’s how I installed on CentOS 7.

Fresh CentOS 7 Install
$ yum update

$ yum install wget
$ yum install unzip

Let’s Encypt (install):
download and extract lets encrypt zip archive
$ cd /var
$ wget https://github.com/letsencrypt/letsencrypt/archive/master.zip

$ unzip master.zip

$ cd letsencrypt-master
$ sudo ./bootstrap/centos.sh

$ virtualenv --no-site-packages -p python2 venv
$ ./venv/bin/pip install -r requirements.txt acme/ . letsencrypt-apache/ letsencrypt-nginx/

Let’s Encrypt (Get Certificate)
$ sudo ./venv/bin/letsencrypt -d domain_name --apache-ctl apachectl auth


#4

I did the same on Amazon Linux. Error on “$ sudo ./venv/bin/letsencrypt -d domain_name --apache-ctl apachectl auth”.
PS. What means --no-site-packages". I is not changed


#5

Don’t know what --no-site-packages means. It’s in the install instructions.
https://letsencrypt.readthedocs.org/en/latest/using.html

Try without the --apache-ctl apachectl option. I had to had that because my apache ctl is not the default.


#6

In this topic is my log file. Install error. Amazon Linux AMI
You can look and say what wrong?