Installing certbot-auto giving "probably a dependency cycle" on Ubuntu


#1

When installing certbot-auto on my web server, I get the error:

E: Couldn’t configure pre-depend upstart-job for hostname, probably a dependency cycle.

OS: Ubuntu 9.04
Commands tried:
apt-get -f install
apt-get autoremove // To clean up some old dependencies
apt-get clean // because why not

Full output of apt-get -f install

The following packages were automatically installed and are no longer required:
sun-java5-jdk sun-java5-demo libmpfr1ldbl cpp-4.3 libdigest-sha1-perl
Use ‘apt-get autoremove’ to remove them.
The following extra packages will be installed:
hostname initscripts
The following packages will be upgraded:
hostname initscripts
2 upgraded, 0 newly installed, 0 to remove and 297 not upgraded.
37 not fully installed or removed.
Need to get 0B/41.5kB of archives.
After this operation, 170kB disk space will be freed.
Do you want to continue [Y/n]? Y
E: Couldn’t configure pre-depend upstart-job for hostname, probably a dependency cycle.

Any help appreciated


#2

This is a problem with the packages on your Ubuntu box ( not related to certbot ).

are you really on ubuntu 9.04 ? (a very old version of ubuntu that’s well past the End of Life for Ubuntu )


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.