Installed the Certificate but still https is not working in my site

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:www.GoProvia.com

I ran this command:created the certificate using win-acme

It produced this output: Certificate goprovia.com. any host created

My web server is (include version):IIS 10.0

The operating system my web server runs on is (include version):Windows Server 2016

My hosting provider, if applicable, is:AWS Lightsail

I can login to a root shell on my machine (yes or no, or I don't know):Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):win-acme

1 Like

Welcome to the Let's Encrypt Community :slightly_smiling_face:

I don't have much with which to work here, but perhaps you overlooked restarting your webserver after installing the certificate?

1 Like

Yes, I have restarted IIS after installing the certificate. I can see the certificate bindings in the iis.
Do you need more information to help me fix this issue?

1 Like

I'm getting no response (i.e. port closed) on port 443 (SSL) for https://goprovia.com and https://www.goprovia.com. There may be a problem with your webserver configuration. Do you have any error logs?


----- Certificate History -----
1 Like

Any steps to check? I can see www.goprovia.com is working fine but only the secure site is not working.

1 Like

Without any logs, I'm rather working blind.

1 Like

Please let me know what log info do you need?

1 Like

Try making sure you are allowing inbound traffic on port 443 first.

1 Like

Yes I have already checked the inbound rule for the port 443 and its enabled.

1 Like

Go to Control Panel->System then Security->Windows Firewall->Allowed Programs and verify that you have Secure World Wide Web Service (HTTPS) and Domain, Home/Work, and Public both checked.

1 Like

Can you connect to it securely locally?
[from the same system and from any other local system]

As this seems to be the first time this system uses LE and Win-ACME, I would suspect that things need to be worked out before going into production.
If so, try using the staging environment until things work as expected.

1 Like

No It was not working locally in the same system

1 Like

Yes, I have checked this settings too. It was public.

1 Like

Can you also connect to it from the Internet?

1 Like

If it was not working locally, why would it be working from the internet?

1 Like

Have you since gotten it to work?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.