Installed SSL Certificate successfully on a website, still getting the “your connection is not secure” message

#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: https://itzbhushan.com

I ran this command:

It produced this output:

My web server is (include version): Not sure

The operating system my web server runs on is (include version): Not sure

My hosting provider, if applicable, is: Google domains.

I can login to a root shell on my machine (yes or no, or I don’t know): no.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.30.0

https://crt.sh/?q=itzbhushan.com shows that my new certificate expires on 2019-07-15 while https://www.whynopadlock.com/results/d98b444d-1030-4e6e-9ec5-d7b1c3b5b9cc shows that my certificate has expired.

Here is what happened: I used certbot certonly --manual -d itzbhushan.com --preferred-challenges dns to generate a TXT record, update google domains with the data and the command was able to successfully validate my key. When my certificate expired, I reran the same command, generated a new TXT record and the update was successful. However, I still get an https error.

#2

Hi,

When you use manual to create a new certificate, it will be stored in a different path than the previous one, which means you’ll also need to dive in your web server and change the certificate paths.

To find out the certificate path, you could run sudo certbot certificates and see the output of the valid certificate.

Thank you

#3

Thanks! This helped. I fixed the issue by updating the keys in my webserver (hosted through gitlab pages). I followed instructions here: https://docs.gitlab.com/ee/user/project/pages/getting_started_part_three.html#add-your-custom-domain-to-gitlab-pages-settings

1 Like
closed #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.