Install Certificate on Apache not working


#1

My domain is: technet.ovh

I ran this command: sudo certbot certonly --standalone -d technet.ovh

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for technet.ovh
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. technet.ovh (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://technet.ovh/.well-known/acm e-challenge/FrmdP-oF-CxxEFI5BqACjiRXAFIbeBb8eOF9zJn7I1M: “\n\n404 Not Found\n\n

Not Found</h 1>\n<p”

IMPORTANT NOTES:

My web server is (include version): Apache 2.4.25

The operating system my web server runs on is (include version): Raspbian (last version)

My hosting provider, if applicable, is: OVH

I can login to a root shell on my machine (yes or no, or I don’t know): yes

Can anyone help me ?
Thanks


#2

Hi @C9H13N

you have an ipv4 and an ipv6 address. But the ipv6 doesn’t work.

https://letsdebug.net/technet.ovh/5940?debug=y

So remove your ipv6 setting.


#3

Thanks @JuergenAuer
I removed the AAAA record but i still have the same error output :confused:


#4

You have a running Apache. So use that, not the --standalone.

sudo certbot certonly --apache -d technet.ovh

or (if you have an unusual configuration) use the --webroot authentication.

sudo certbot certonly --webroot -w yourwebroot -d technet.ovh

#5

Thanks a lot ! Now I have an other problem but i know how to solve it. :smile:


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.