Individual certificates for multiple subdomains


#1

Please fill out the fields below so we can help you better.

My domains are: anatheria.com, images.anatheria.com, theme.anatheria.com
I ran this command: certbot-auto
My operating system is (include version): Ubuntu trusty
My web server is (include version): apache 2.4.18
I can login to a root shell on my machine (yes or no, or I don’t know): yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

I have 3 conf files in sites-available:
004-anatheria-images.conf - this is for images.anatheria.com
004-anatheria-theme.conf - this is for theme.anatheria.com
005-anatheria.conf - this is for the main website

when running certbot-auto and choosing the (sub)domains that I want to register, it only sets up the redirect in 005-anatheria.conf and creates a 005-anatheria-le-ssl.conf - it ignores the other conf files

If i run the command again and only choose images.anatheria.com, the only file it changes is 005-anatheria-le-ssl.conf and the only change it made was to point at the new certificate.

Do I have to do the conf adjustments manually in this instance?


#2

I managed to get what I wanted to work by temporarily taking the 005 confs out of the sites-available directory and running certbot-auto again. after it generated the corrected configs I put the 005 confs back in.


#3

@bmw, this sounds like it could be an problem in the Apache plugin’s parser?


#4

In case it’s relevant:
The 005 config also has *.anatheria.com in it as a ServerAlias.


#5

@pyroneus, are you able to provide a full Certbot log (located in /var/log/letsencrypt by default) as well as the files containing the relevant vhosts? Feel free to redact values as you feel appropriate. You can also e-mail them to me if you prefer at my username @eff.org.


#6

I sent them to your email address. Can you please confirm you have received them?


#7

I got your e-mail. Thanks @pyroneus.

I confirmed that this is a bug. Thank you for reporting it. I created #4517 on Certbot’s GitHub repo to investigate the issue.


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.