Incorrecty Configured WordPress Plugin Does Not Use HTTPS For Pintrest


#1

RESOLVED: THIS ISSUE WAS AS A RESULT OF MIS-CONFIGURATION. I used a plugin to configure on Wordpress and there was a setting that was not configured properly. I could not delete the post. Found it shortly after posting this.

I am hoping some super savvy person can help me. Before I state information, I want to say that I manage my own ecommerce site with digital downloads. I am not a developer by trade, but just trying to keep my website operational and secure to the best of my abilities. I do not have the funds to hire somebody and I do have an IT background but not in web development.

PROBLEM: I was using Pinterest to Pin product URLS prior to upgrading site to SSL. I know I should have done it from the get go, but I was new and payment portion was redirected to secure site. Regardless, I finally setup my website with SSL in late March, I think. At that point, site had been up and operational for a year. Thus, to market my product, I have a Pinterest page to pin to different product with HTTP:// URL. Any Pins linked to the HTTP URL are not redirecting to HTTPS URL. This is what is redirects to, which I want to stop happening: https://www.simplycraftysvgs.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.simplycraftysvgs.com%2Fwp-admin%2F&reauth=1, which is my Wordpress login page. I do not like that at all!
Is there any way to still open a URL using HTTP or change the redirect to work? I know this is not a direct SSL question, but the change to Let’s Encrypt is definitely affecting Pinterest and I am stuck. I was hoping there was something I could add to my website to fix this issue. I do have a support inquiry into Pinterest, but only got one response back thus far with links to Help links, like I did not look that up. I have spent hours trying to figure this out. If I use a standard browser, HTTP just redirects to the HTTPS version.

This only happened after configuring the Let’s Encrypt SSL certificate on my website. Here is some basic information.
URL: www.simplycraftysvgs.com
HOST: siteground, using WordPress
Name and version of operation system…not sure. Tried looking it up on

Any help is truly appreciated. I am going around in circles.

Sandy


#2

hi @cutty3d

I think you should leave the post. It’s good for others to review.

Often LetsEncrypt is the first that is blamed and it’s good to have answers for others.

Andrei


#3

Of course. It was a simple fix. Really a newbie issue. Let’s Encrypt SSL certification itself was not the issue. It was the way it was configured, which was really me not knowing enough. I read through a bunch of the FAQs on Let’s Encrypt and then realized I installed the Really Simple SSL plugin to configure my certificate in Wordpress. Of course, everything else appeared to be working on my site, so I did not understand this Pinterest issue. Bottom line is this…I had enabled 301 .htaccess redirect, but not the WordPress 301 redirection to SSL. Since my ecommerce site is build on Wordpress, thus appears to be the problem. That issue was not occurring when I manually accessed the website, so I did not think that was the issue. I enabled this and Pinterest links work again.

Maybe this will hope somebody else.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.