Impossible to get certificate. Is Online SAS over?

Is their a problem with one of your DNS test server?
Since 2 days I have a problem to get certificates
I have tried dnsckecker and it seems Online S.A.S. is over. Is it the raison?

My domain is:

I ran this command:

certbot certonly --manual --manual-auth-hook /etc/letsencrypt/ --preferred-challenges dns --email []redacted --debug-challenges -d,,,,,,

It produced this output:

Certbot failed to authenticate some domains (authenticator: manual). The Certificate Authority reported these problems:
  Type:   dns
  Detail: DNS problem: NXDOMAIN looking up TXT for - check that a DNS record exists for this domain

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Our

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.21.0

i got name not resolved error, is your server online?(try over mobile data)


First, your DNS has some problems. See DNSViz for details (link here)

Also, it looks like you CNAME that to acme-dns. Have you set that up properly?

dig TXT 295 IN CNAME

What a fool I am.

I forgot the dot at the end of the DNS statement. shame on me!


1 Like

Using this online too can be of help, here are the results I got Let's Debug please review them.

A side note:
Testing and debugging are best done using the Staging Environment as the Rate Limits are much higher. Rate Limits are per week (rolling).


Note that error is for the apex domain but they are not requesting that name in the cert. All names in the cert were for various levels of subdomains of that. If they don't plan to use the apex name (and it doesn't look like they are), the missing A/AAAA records are expected.


Sorry missed that, however DNS-01 Challenge also is having issues results here Let's Debug

1 Like

Yes, and I already posted link to DNSViz which describes some DNS errors for the domain names in question


I probably should drink more :coffee: before reading . . . :roll_eyes:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.