I'm getting an HTTP 500 error when trying to access my website

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:
I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

I am unable to access my website and my hosting company informed me it is because of this plugin. I've been using it for over a year for my SSL, but now its causing me to get an HTTP 500 error. If someone there can help me it would be greatly appreciated. Thanks!

Could you elaborate more about "this plugin"? Which plugin? What do you mean by that?


I also would like to know more what you mean by "plugin".

I'll add that your cert looks fine. See this SSL Decoder site to see for yourself. Your cert will expire in 45 days.

I also get an http error 500 when using a browser (or curl) for your domain. I connect using http and get redirected by your server to https which returns the http 500.

Using openssl I get a 400 error page (as expected) but it mentions cPanel. Have you changed anything in your cPanel config that might cause this?


I am using the free version of the LetsEncrypt WordPress plugin. I had been updating it every 90 days per the instructions for the free version of the plugin. This has worked fine for me for the past year and my site was working, but I noticed about 3 days ago I was getting the error message and I also can't access the WordPress sign in page. I have not made any changes on my cPanel.

There are many WordPress plugins for Let's Encrypt. Do you have a link for your specific one? I don't think it is related to your http 500 problem. As I noted, your cert looks fine and you renewed it 45 days ago so your system was working fine then.

Your crt.sh history shows you usually only renew your cert after the old one expires. Did you try to renew it early this time?

Here are some ideas for debugging common http 500 problems with Apache and cPanel. One of the most common problems is having a mis-coded htaccess file. Let us know what you find


Thanks for looking into this. I will have to get you the plugin link when I get home from work.

I always renew the cert after it expires and I've never had a problem in the past. I haven't touched the htaccess file as it isn't required to renew the cert.

I will try your suggestion of debugging http 500 problems and let you know how it goes. Thanks again for your help!


I've never heard about certificates themselves resulting in a 500 internal server error. Note that Let's Encrypt does not build plugins: those are all "third party" plugins using/abusing the name Let's Encrypt. I recommend to contact the support of the plugin you're using and perhaps also ask your hosting company for as much details as possible, as "because of this plugin" does not provide much information to debug your issue.


Thanks for the help. I checked with my hosting company and they said "There was wordpress core files issue" it apparently didn't have anything to do with the cert as the previous rep had indicated, so sorry for the confusion.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.