I tried installing passbolt i get this error

Just in case its not obvious to you, to use Let's Encrypt to get a certificate you either need:

  • a public web server for your domain that Let's Encrypt can make a request to over http (tcp port 80) - this is http validation
  • or, use DNS validation to create a temporary _acme-challenge TXT record in your public DNS, this works best if the ACME client you are using (whatever passbolt has built in) can talk to your DNS provider API to update the TXT record. Many tools cannot do this.

You can also get a certificate using a different machine etc and copy the certificate files to your server, but this is more difficult. The easiest method is to have your server be accessible over the public internet on TCP port 80 (http). This requires enabling TCP port 80 on any firewalls you have including any cloud hosting platform you are using for your server etc, it may involve port forwarding from your internet router to the correct server internally, if you are self-hosting.

[Note that you can enable TCP port 80 access, perform your setup, then disable port 80 again but you will need to re-enable port 80 access to complete future certificate renewals]

6 Likes

I Got My ssl certificate for domain name still it has this problem

Can you explain more what you are trying to do?

Because I see a valid Let's Encrypt cert issued today for arcanes.in and www.arcanes.in that is being used for both IPv4 and IPv6 domains.

So, why do you need another cert?

And, I only see responses from a LiteSpeed server but you are using the --nginx option in Certbot. Why did you use --nginx?

4 Likes

I am trying to host an passbolt in my local server I try to install it with the given steps I get this error

You might be better served using their Community Forum https://community.passbolt.com/
And their GitHub Passbolt ยท GitHub

2 Likes

But, a LiteSpeed server is responding to requests to your domain. passbolt uses nginx or Apache.

Are you using LiteSpeed as just a proxy to nginx?

Do you see this test request show up in your nginx access log?

curl -i http://arcanes.in/.well-known/acme-challenge/TestToNginx.html

You should see a 404 Not Found logged in nginx access log for that request. I just made one. You can also make similar requests to test that. When you use the --nginx option Let's Encrypt needs to talk to your nginx server.

But, this is what happens. Note LiteSpeed. And, I see Hostinger but you earlier mentioned GoDaddy. Did you switch?

Are you sure your DNS is pointing to the right server?

curl -i http://arcanes.in/.well-known/acme-challenge/TestToNginx.html
HTTP/1.1 404 Not Found
server: LiteSpeed
platform: hostinger
content-security-policy: upgrade-insecure-requests
4 Likes

Then you should check if you already have a cert
With:
certbot certificates
And, if so, stop trying to get another one and just skip the "get a cert" step(s) and just do the "use the cert" step(s).

3 Likes

Yes I Switched To Hostinger

Is that on a shared plan OR do you have root access?
Can you run?:
certbot certificates

If so, please show the output.

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.