I tried installing passbolt i get this error

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:arcanes.in

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version): ubuntu 22.04.2

My hosting provider, if applicable, is: godaddy (Dont have any specific hosting plans)

Hello @ritesh, welcome to the Let's Encrypt community. :slightly_smiling_face:

Using the online tool Let's Debug yields these results https://letsdebug.net/arcanes.in/1554400

ReservedAddress
Fatal
A private, inaccessible, IANA/IETF-reserved IP address was found for arcanes.in. Let's Encrypt will always fail HTTP validation for any domain that is pointing to an address that is not routable on the internet. You should either remove this address and replace it with a public one or use the DNS validation method instead.
192.168.0.195 

The IPv4 Address of 192.168.0.195 is in a Private network - Wikipedia range.

1 Like

Here is what nslookup gets; the third DNS A Record you need to remove.

$ nslookup arcanes.in ns29.domaincontrol.com.
Server:         ns29.domaincontrol.com.
Address:        97.74.104.15#53

Name:   arcanes.in
Address: 76.223.105.230
Name:   arcanes.in
Address: 13.248.243.5
Name:   arcanes.in
Address: 192.168.0.195
2 Likes

will removing the ip work

Not removing the IPv4 Address of 192.168.0.195 will not work. Any IP Address that cannot be accessed from everywhere on the Internet will not work.

1 Like


I Get The same Error

What Should i do i am very new to these concepts

You have a "URL Redirect" or "URL Forward" setup in GoDaddy DNS section. That won't work for HTTPS sites.

You should disable that feature and instead create an A record with the address of your public IP. GoDaddy should inform you of this value somewhere. Or, this can show it:

curl -4 https://ifconfig.io
3 Likes

I don't have "URL Redirect" or "URL Forward" setup in GoDaddy DNS section
and I tried replacing the public IP but that too doesn't work

Very little has changed:

Name:      arcanes.in
Addresses: 76.223.105.230
           13.248.243.5
           183.82.31.230
3 Likes

sorry sir I did not get it

What did you not get?

2 Likes

like i have changed it to public ip now i see the same result

You may need to remove the other A records.

4 Likes

Well, two of your 3 DNS IP addresses point to "AWS Global Accelerator"

We often see that with these features because GoDaddy uses AWS for this service.

It looks like your 3rd IP might now be your public IP. So, just remove those other 2

5 Likes

The last Problem has Solved and now this !!!

You need to run Certbot on a server that is able to receive connections from the rest of the Internet. Currently 183.82.31.230 is not the address of such a server, apparently because of a firewall configuration.

5 Likes

Your Port 80 (and 443) are not OPEN

$ nmap -Pn -p80,443 arcanes.in
Starting Nmap 7.80 ( https://nmap.org ) at 2023-07-18 19:59 UTC
Nmap scan report for arcanes.in (183.82.31.230)
Host is up.
rDNS record for 183.82.31.230: 183.82.31.230.actcorp.in

PORT    STATE    SERVICE
80/tcp  filtered http
443/tcp filtered https

Nmap done: 1 IP address (1 host up) scanned in 3.61 seconds
2 Likes

Progress!

Your using HTTP-01 authentication.
That requires that your server be accessible from the Internet on HTTP port 80.

4 Likes

Thank you All for the Support :blush:

4 Likes