I renewed my certificate but browsers don't know there is a new certificate for this website

My domain is: doronbehar.com and I use GitLab pages to serve my website. In order to have my website support SSL, I use certbot to get the acme challenge and I put the proper file with the correct content in my website’s git repository during the validation process:


I did this process with my previous certificate and it worked and I had SSL for my website for the rest of the certificate.

A few weeks ago, I received an email saying my current certificate should expire in a month or so. I ran this command: certbot certonly --domain doronbehar.com --manual in order to renew my certificate, everything worked like in the initial certificate creation process.

The problem is that now, from some reason browsers don’t accept my certificate, saying it has expired. I renewed it a long time ago (here is the commit) and it was a month or so before the expiry date but I haven’t noticed the problem until now.

Does anybody knows how to explain this? Is it because letsencrypt didn’t issued (not sure it is the right term) new certificates for the browsers?

I just encountered this thread: Renewed certificate for my website hosted in Gitlab Pages isn't getting updated!

And I found the solution there, just posting the answer here to make it clear:

When using gitlab pages, one needs to update the certificate on their control panel - delete the domain and add it again with the contents of fullchain.pem in the public key text field and the contents of privkey.pem in the private key text field

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.