I accidentally deleted /etc/letsencrypt/ : unable to generate a new certificate

I succeeded in creating a new certificate for my domain, but firefox keeps telling me that the certificates is expired since June the 1st.
What did I do wrong ?

Thank you in advance !

My domain is: fwzte.xyz

I ran this command: sudo certbot certonly -a manual -d fwzte.xyz

It produced this output:

  • Congratulations! Your certificate and chain have been saved at:
    /etc/letsencrypt/live/fwzte.xyz/fullchain.pem
    Your key file has been saved at:
    /etc/letsencrypt/live/fwzte.xyz/privkey.pem
    Your cert will expire on 2019-09-30. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot
    again. To non-interactively renew all of your certificates, run
    “certbot renew”

My hosting provider, if applicable, is: gitlab pages

I can login to a root shell on my machine (yes or no, or I don’t know): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0

FYI, i ran a domain check which is available here : https://check-your-website.server-daten.de/?q=fwzte.xyz

There is 3 duplicates, but I can not restart the webserver.

What can I do ?

1 Like

Hi @MmeQuignon

if you use certonly, the certificate isn't installed.

What says

certbot certificates

I'm not so firm with these Gitlab pages. /.well-known/acme-challenge is redirected to

https://gitlab.com/-/acme-challenge?domain=fwzte.xyz&token=check-your-website-dot-server-daten-dot-de

But is it possible to install a certificate? How did you install the older certificates?

Damn…

I was reading the procedure I followed the first time.
When you don’t make a new cert, you just have to renew and that’s it.
But I forgot the final step…

I’m so sorry…

By the way, there is the procedure : https://docs.gitlab.com/ee/user/project/pages/lets_encrypt_for_gitlab_pages.html

Thank you for your help, and sorry for the noise !

2 Likes

Ah, thanks, good to know.

sudo certbot renew

Perhaps a restart of the webserver is required.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.