HTTPS server not connecting

My domain is: blakewright.net

I ran this command: sudo certbot certonly --standalone -d blakewright.net

It produced this output: It creates the keys and I have them in my nodejs server but it does not seem to connect. I am just seeing if somebody may be able to help me troubleshoot this as I cannot figure out where I am going wrong. I can provide any additional info that would be helpful.

I also tried running the --webroot version of the command while my server was running but it returns

Certbot failed to authenticate some domains (authenticator: webroot). The Certificate Authority reported these problems: Domain: www.blakewright.net Type: unauthorized Detail: Invalid response from http://www.blakewright.net/.well-known/acme-challenge/kf_sLn6Gen7OHyB-Lp5SetMC8n3o6KKg-IMfQMj2z3Y [54.156.104.102]: "<!DOCTYPE html>\r\n<html lang=\"en\">\r\n\t<head>\r\n\t\t<meta charset=\"UTF-8\" />\r\n\t\t<meta http-equiv=\"X-UA-Compatible\" content=\"IE=edge\" /"

Hint: The Certificate Authority failed to download the temporary challenge files created by Certbot. Ensure that the listed domains serve their content from the provided --webroot-path/-w and that files created there can be downloaded from the internet.

When I do spin up the server again it still runs on port 80 and connects thru http with no problems. It even says listening on 443 no errors, but I can't seem to connect with https and I can't figure out why.

My web server is (include version): nodejs/ expressjs

The operating system my web server runs on is (include version): Ubuntu 20

My hosting provider, if applicable, is: AWS lightsail

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.16.0

1 Like

Welcome to the Let's Encrypt Community, Blake :slightly_smiling_face:

So it looks like there is a firewall somewhere blocking port 443. This is why Open Port Check Tool - Test Port Forwarding on Your Router reports port 443 as closed.

You might start here to fix this: