Https not working in my country?


#1

Please fill out the fields below so we can help you better.

My domain is: https://egyptadviser.com/

I ran this command: i’am user {Add Let’s Encrypt} feature on Kloxo-MR 7

It produced this output: added

My operating system is (include version): CentOS release 6.8 (Final)

My web server is (include version): Nginxproxy

My hosting provider, if applicable, is: i have my won vps on digitalocean and use Kloxo-MR 7 as control panel

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Kloxo-MR 7

My issue is : ’ https://egyptadviser.com/ ’ if you brows website it’s working with you, but it’s not working on my country (Egypt) !! i don’t know why !!


#2

When you say it’s “not working” … in what way is it not working ? an error message ?


#3

You’re not very clear about what the problem is. I can open the page here (in Australia), what message are getting in Egypt? Is the page untrusted, or does it not display at all?

Also, have you tried using more than one browser? It’s possible a browser like Firefox may work where Chrome and Edge do not. Mozilla uses it’s own certificate repository as opposed to using the operating system’s repository. (Is it possible that your OS has region specific restrictions?)


#4

i’am tried to brows with firefox, opera, chrome .
it’s not display at firefox
and this is message on opera

This site can’t be reached

egyptadviser.com took too long to respond.
Try:

Checking the connection
Checking the proxy and the firewall
Check your internet connection.
Check any cables and reboot any routers, modems, or other network devices you may be using.
Allow Opera to access the network in your firewall or antivirus settings.
If it is already listed as a program allowed to access the network, try removing it from the list and adding it again.
If you use a proxy server...
Check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don't believe you should be using a proxy server: Go to the Main menu > Settings > Change proxy settings... > LAN Settings and deselect "Use a proxy server for your LAN".

i’am tried brows from more than computer used difference ISP

but it working when use TOR !! so it’s not working with Egypt only !


#5
This site can’t be reached

egyptadviser.com took too long to respond.
Try:

Checking the connection
Checking the proxy and the firewall
Check your internet connection.
Check any cables and reboot any routers, modems, or other network devices you may be using.
Allow Opera to access the network in your firewall or antivirus settings.
If it is already listed as a program allowed to access the network, try removing it from the list and adding it again.
If you use a proxy server...
Check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don't believe you should be using a proxy server: Go to the Main menu > Settings > Change proxy settings... > LAN Settings and deselect "Use a proxy server for your LAN".

#6

can you reach the non-https version ?

What does “curl -I egyptadviser.com” give ?


#7

yes i can brows http:// with out any problem

“curl -I egyptadviser.com” give

$ curl -I egyptadviser.com
HTTP/1.1 200 OK
Server: nginx/1.11.3
Date: Tue, 16 Aug 2016 10:31:18 GMT
Content-Type: text/html; charset=UTF-8
Connection: keep-alive
Vary: Accept-Encoding
X-Powered-By: PHP/5.6.24
X-Hiawatha-Cache: 5
Set-Cookie: _icl_current_language=en; expires=Wed, 17-Aug-2016 10:31:17 GMT; Max-Age=86400; path=/
Set-Cookie: _icl_current_language=en; expires=Wed, 17-Aug-2016 10:31:17 GMT; Max-Age=86400; path=/
X-Pingback: http://egyptadviser.com/xmlrpc.php
Link: <http://egyptadviser.com/wp-json/>; rel="https://api.w.org/"
Link: <http://egyptadviser.com/>; rel=shortlink
X-Content-Type-Options: nosniff
X-XSS-Protection: 1;mode=block
X-Frame-Options: SAMEORIGIN
Access-Control-Allow-Origin: *
X-Supported-By: Kloxo-MR 7.0
X-Micro-Cache: MISS

#8

OK, thanks - that helps narrow things down. What about

curl -I https://egyptadviser.com

?


#9
curl -I https://egyptadviser.com
curl: (28) Operation timed out after 0 milliseconds with 0 out of 0 bytes received

#10

Have you got any plugins in your wordpress that block certain IP ranges ?


#11

no i didn’t add any plugin related with IP’s


#12

There have been some reports about Egyptian ISPs interfering with encrypted connections recently. Could you get someone to test it from a different ISP in Egypt, and from an ISP in another country?

By the way, I was just able to connect from the United States, so if you’re still having trouble, the problem could well be with your ISP blocking connections.


#13

Your site works fine in Canada.

Sounds like a problem with your local connection/ISP/censorship.

Well does HTTPS work on this forum? Google?


#14

yes https working properly with this site anf google, facebook, twitter … and any another website :smiley:


#15

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.