Https not working even after successful certbot in AWS LightSail

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo certbot --apache

It produced this output: I could complete the steps successfully

My web server is (include version): apache 2.4 (sudo yum install httpd)

The operating system my web server runs on is (include version): CentOS 7.8 2003

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 1.3.0

I was able to access my website using IP address and domain name before running certbot.
After running certbot successfully, I could not access the website using domain name.
I can still access it using IP address.

I used sudo certbot --apache
I selected Both domains: and
I chose: [2] Redirect
And, finally I got congratulations message.

Note: This is a new server and I have updated the DNS too.

Please help.

1 Like

certbot --apache rollback

[which should undo the last changes made by certbot]

If that corrects the problem, retry but without redirection option.

1 Like


I ran certbot --apache rollback.
Then, I checked certbot certificates.
The certificate still exist. It is not removed.

Kindly help.

1 Like

I think you misunderstood the --rollback effect.
It will not remove the cert.
It will roll back the Apache config as it was just before the most recent certbot change.

Having a cert is not relevant to the problem:

1 Like

Thank you for helping me to understand. I ran sudo certbot --apache again; this time with No redirect option.

I got

Congratulations! You have successfully enabled and

But https is not working. Kindly help.

1 Like

In what way is it “not working”? What error message do you get?

For me, connecting to your site over HTTPS times out. Make sure your firewalls – your AWS security groups and anything installed on your server – allow port 443.


@mnordhoff, you are right!

httpd conf, firewall settings and everything on my server looked good.

But, I missed one place. I’m using AWS LightSail and I forgot to add/open the port 443 in LightSail/Networking/Firewall.

Thank you @rg305 and @mnordhoff for your time.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.