How to Setup a SSL for my Subdomain which forwarded to my Local Server

Hello I have this Setup

My domain is:, i want to create a subdomain with https ie.

this subdomain only an A in DNS Records which pointed to a public IP (firewall/proxy) that forwarding to my local server ( I can access in my intranet

Is it possible to use https on my intranet ? like accessing from my intranet.

If by “” you actually mean a real public domain, then yes.

There are several ways to authenticate and obtain a cert.
The first choice on that path is can the Internet reach your portal server via http (port 80)?
Then which O/S does the web server run on (and version)?
Then which web server does it run (and version)?

Have a look at:


I can make it happend for my local server to reach internet

i’m using windows server 2012 R2

webserver is IIS

Thank you

hello ,

I managed to get my certificate onmy intranet but when i access my intranet from outside im getting an error “ERR_SSL_PROTOCOL_ERROR”

any idea what might i do wrong ?

Thank you

Hi @b0n4r

to check your configuration your domain name is required.

@JuergenAuer it’s

Checking your domain there are older checks - - last with Grade W, http works, https not.

But my browser says, now the url works. Rechecked the domain, again Grade W, https doesn't work.

Perhaps there is a blocking firewall so it's impossible to use online checks.

And there are some errors, missing files.

1 Like

do you mean the i should enable the inbound for port 443 ?

If you want to use online checks, that's required.

Now port 443 is open - and Grade I -

Missing CSS- and JavaScript files.

1 Like

but still i’m getting err_connection_reset or SSL_PROTOCOL_ERROR
btw can you access it ?

That's the reason you should use online tools. Then you can test such things.

Perhaps your ciphers are too low/weak/insecure for your client:
[there are only two GREEN ciphers, but even they use very weak DH keys]

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.