How to get a cert for brewed Apache 2.2 on OS X


#1

Hi,

I have a mac mini next to me with OS X running a VM with also OS X (10.11.3) and a brewed apache 2.2 for my owncloud 8.2.3. It runs perfectly.
Then I have (just) a domain at the german provider “1und1” pointing to my “dnydns”-domain which is getting the IP from my fritz box at home. Now I tried to get a certificate without success.
Shortly:
www.mydomain.de --> https://mydomain.goip.de/apps/owncloud --> fritzbox (portforwarding 443 --> 443) --> apache 2.2 on VM --> owncloud

I read a lot of threads and googled around and found a lot of good information:
I tried --manual, --webroot and --standalone
I bypassed the dyndns-domain by pointing directly to my homes IP (and also changed the path)
I made a 2nd port forwarding with 80 --> 80 in the fritz box
I also started a SimpleHTTPServer
I used different options on the lets encrypt client
I googled the error messages
In some days I got very far and learned a lot but nothing helped.

I have a domain and I have a server now I would like to have a certificate. What I have to do?

BR
Clemens


#2

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.