How to disable port calls redirecting to https

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: nestedvar.dev

I ran this command:

It produced this output:

My web server is (include version): apache2 (i cant figure out how to get the version i just installed it today

The operating system my web server runs on is (include version): Ubuntu server 18.04

My hosting provider, if applicable, is: selfhosting on a dedicated machine

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0

I’m needing to not redirect the port call of port 9000 (nestedvar.dev:9000) to https (IE: not having https://nestedvar.dev:9000 as the final url of the site)
I have a docker container that contains a web application that listens on port 9000 and I can’t connect to it cause certbot/letsencrypt redirects my connection to https how can I disable the redirect
I’ve tried connecting in edge chrome internet explorer and firefox and all of them redirect to https
If you need any further information please request it

First of all, .Dev domains are being forced to use HTTPS (HSTS preloaded at tld level) thanks to Google.

Have you obtained any certificates? If not, you’ll not be able to use .Dev domain (doesn’t matter what port you connect to, HSTS is enforced)

If you don’t have a certificate, you need to obtain one now and use port 9000 over TLS/https.

I have a certificate for the base domain and I dont know how to obtain a certificate for port use would you mind walking me through it or providing some links that I could follow to get a cert for the port

Hi @ExZiByte1

you don’t need a second certificate (there is a rate limit).

You can use the same certificate with different ports. A certificate doesn’t know something about a port.

Could you help me set that up so the certificate will cover the port?

You need to search the appropriate documentation for whatever software is responding on port 9000, and install the certificate according to its requirements.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.