How can I change the installer from none to IIS Web

My domain is:

Some certificates were originally created with the option to not run an installer. How can I change this so that renewals use an installer? Also how can I tell which certificates will use an installer next and which will not?

My web server is (include version): IIS 10
The operating system my web server runs on is (include version): Windows server 2016 Datacentre
I can login to a root shell on my machine (yes or no, or I don’t know): Yes
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):v1.9.11.2

Hi @Campbell_McCracken

I don't understand your question.

Your domain

has a new Letsencrypt certificate ( )
expires in 90 days, - 2 entries

created today, with both domain names (www and non-www), both connections are secure.

There are some other errors (check the result), but your certificate is good.

When I use LetsEncrypt on my server, using the Win-acme interface, I get an option to run an installer script after the certificate has been created. Some of my domains were originally set up to not use an installer - I originally set up bindings manually. This continues when the certificate is renewed - I have to set up bindings manually each time. I would like to change this so that the bindings are automatically set up. I can do this when I set up a new domain, but can’t find a way of changing the way the renewal of old domains works.

Hi @Campbell_McCracken, welcome to the community forum.

Your question strikes me as pretty specific to WinACME. Someone in the forum may know the answer but if you don’t get a reply I’d suggest trying to open an issue with the maintainers of WinACME seeing if they know the answer.

Good luck!

Ah, good to know. But I don't know an answer, I don't use that client.

But checking that source

you can add a --installation script - parameter.

Thanks. I’ll try the PKISharp links.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.