Hoster blocks https and shows suspended-page - http works, first certificate created

How do I ask questions in here? I only seem to replay…wheres the option for asking questions?

Hi @prottay2

now you have your own topic :wink:

“New Topic” - that starts a new thread.

Share your question, perhaps change the title (or I change it).

There is a standard template of #help


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

My domain is:paperinmusic.com

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine

Hi @prottay2

checking your domain ( https://check-your-website.server-daten.de/?q=paperinmusic.com ):

You have one new certificate

CertSpotter-Id Issuer not before not after Domain names LE-Duplicate next LE
930512670 CN=Let’s Encrypt Authority X3, O=Let’s Encrypt, C=US 2019-05-25 10:59:08 2019-08-23 10:59:08 mail.paperinmusic.com, paperinmusic.com, www.paperinmusic.com
3 entries duplicate nr. 1

There is no older certificate, so it’s your first certificate.

Your standard-urls:

Domainname Http-Status redirect Sec. G
http://www.paperinmusic.com/
107.167.82.131 301 http://paperinmusic.com/ 0.353 D
http://paperinmusic.com/
107.167.82.131 200 4.536 H
https://paperinmusic.com/
107.167.82.131 302 https://paperinmusic.com/cgi-sys/suspendedpage.cgi 1.673 N
Certificate error: RemoteCertificateNameMismatch
https://www.paperinmusic.com/
107.167.82.131 302 https://www.paperinmusic.com/cgi-sys/suspendedpage.cgi 1.470 N
Certificate error: RemoteCertificateNameMismatch
https://paperinmusic.com/cgi-sys/suspendedpage.cgi 200 1.413 N
Certificate error: RemoteCertificateNameMismatch
https://www.paperinmusic.com/cgi-sys/suspendedpage.cgi 200 1.433 N
Certificate error: RemoteCertificateNameMismatch

The certificate you use looks like it is from your hoster:

CN=aaeepuc.com
	05.05.2019
	03.08.2019
expires in 69 days	
aaeepuc.com, mail.aaeepuc.com, www.aaeepuc.com - 3 entries

And really curious:

Your http version works, there is a WordPress.

The https is redirected to a suspended page:

This Account has been suspended.
Status: 403 Forbidden Content-Type: text/plain; charset=utf-8 403 Forbidden Executing in an invalid environment for the supplied user

So the message is wrong, your account isn’t suspended. Looks like your hoster doesn’t support https, catches https - request and sends wrong html content:

This “suspended page” has wrong html content:

    </body>
</html>
Status: 403 Forbidden
Content-Type: text/plain; charset=utf-8

403 Forbidden
Executing in an invalid environment for the supplied user

It’s a combination of two different messages.

So

  • ask your hoster (or)
  • switch to another hoster with SSL / Letsencrypt support

PS: Now changing your title

When I first got to my cpanel, I was looking for where can I find my ssl, because I didn’t find any https when I searched for my website.

Then I did some research but still I got nothing. In my control panel, there was a security system called ”Let’s Encrypt”. I went there and it looked like everything was fine. But still I didn’t get the “https” on my website. I tried to remove the ssl and get an new one. So I clicked on remove and removed it permanently. Now its gone. The rapid ssl option is almost empty. Now Ii don’t know what to do to get an SSL.

This is my first time that I am creating an website. I got nothing. I set my wordpress to “HTTPS” because my host provider told me that theres an free SSL. Now I see that I don’t have any ssl on my website.

So I need complete help with it from the bingining.

So How do I set a SSL for my website and get HTTPS?

Then you should ask your hoster. Your hoster has a “closed system” that uses Letsencrypt certificates.

But it’s impossible to see what your hoster has created.

What should I ask my hoster?

Tell him what you have done.

But: Is it really impossible to reactivate that?

Perhaps share a screenshot.

What you just asked above:

We can’t answer that within their closed system; only they can.

Problem solved. But my website always loads in this link

https://paperinmusic.com

theres no www. In here. I tried via “Redirect” in control panel but it doesn’t work. Any help on that?

And thanks for you previous responses

Happy to read that you have found a solution.

Now your certificate works.

That’s your configuration.

You have correct www and non-www dns entries ( https://check-your-website.server-daten.de/?q=paperinmusic.com ):

Host T IP-Address is auth. ∑ Queries ∑ Timeout
paperinmusic.com A 107.167.82.131 yes 2 0
AAAA yes
www.paperinmusic.com C paperinmusic.com yes 1 0
A 107.167.82.131 yes

You have a new certificate with both domain names:

CN=paperinmusic.com
	26.05.2019
	24.08.2019
expires in 90 days	
mail.paperinmusic.com, paperinmusic.com, 
www.paperinmusic.com - 3 entries

And you have three correct redirects:

Domainname Http-Status redirect Sec. G
http://paperinmusic.com/
107.167.82.131 301 https://www.paperinmusic.com/ 0.326 E
http://www.paperinmusic.com/
107.167.82.131 301 https://www.paperinmusic.com/ 0.323 A
https://www.paperinmusic.com/
107.167.82.131 301 https://paperinmusic.com/ 1.540 B
https://paperinmusic.com/
107.167.82.131 200 2.670 B

First two correct redirects http -> https without changing the domain name.

Then one redirect from the https + www version to the https + non-www version.

So if you want so use the www version as your main domain: There may be a configuration to change that.

It’s only this last redirect you have to change. Nothing else (not your DNS entries, not your certificate).

How do I change this? Going to the redirect again?

I don’t know. If you use a shared hosting, there may be an option “preferred version”.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.