HELP "Response does not complete challenge" but which one?


#1

I am requesting SAN certificate (48 domains in one), since these domains are located in seperate servers. I configured them to transparently route .well-known requests to my computer where I run letsencrypt client in the standalone mode.

However, I think due to one of them, I get “Response does not complete challenge” error from letsencrypt client. But I can’t locate the domain. It should wrote “Response does not complete challenge faulting domain is ABCDE.com

I tried to test all of them, by copying one of the incoming address to the my browser address bar for all domains.

http://DOMAIN1/.well-known/acme-challenge/Qy0ijNe4sq5C006112YQyUN3Ap6KdnPgl2MgNNMlJ-o
http://DOMAIN2/.well-known/acme-challenge/Qy0ijNe4sq5C006112YQyUN3Ap6KdnPgl2MgNNMlJ-o
http://DOMAIN3/.well-known/acme-challenge/Qy0ijNe4sq5C006112YQyUN3Ap6KdnPgl2MgNNMlJ-o

All of them are work, in order me to further analyze the culprit, I need the information about which domain caused this.

please give my debugging powers a try! At least motivate me about this :’(


#2

Hello @buraktamturk,

Add parameter --debug to your letsencrypt command, you will see more details about the error. Also, take a look to letsencrypt.log. You should find it here /var/log/letsencrypt/letsencrypt.log

Good luck :wink:
sahsanu


#3

Tried the debug switch with no luck :’( . I already looked the log file, all I understand from this log file is some of the challenges does work indeed, but one of them are failing and it blocks entire validation. It does not have any information about the failed domain.


#4

Try to add also parameter -vvvvv to your letsencrypt command.


#5

This switch also logged on the console but still not useful information provided both console and the log file. But I find this switch awesome :smiley:


#6

Then… sorry, I’m out of ideas, maybe some community folk could shed some light on your issue.